r72219 introduced an `_result´ attribute to `TestCase´. As `TestCase´ is designed specifically with the intent that applications should subclass it -- and frequently -- I would suggest that the attribute be given a name less likely to collide with a name chosen by application code. Given the huge quantity of `TestCase´ subclasses, it will likely be a great time saver to address the collision in CPython rather than in each application.
Here's a patch which renames `_result´ to `_resultForDoCleanups´. Another possibility would be for `doCleanups´ to take the result object as an argument. This would make it harder for applications to call directly, though (I've never wanted to run cleanups early, though).
Patch is fine. I'll apply shortly. There was a specific use case for being able to call doCleanups directly which was why the results object needed to be stored.