[issue5804] Add an 'offset' argument to zlib.decompress - Code Review (original) (raw)
Overall, this looks good. Some mostly minor comments in this review.
http://codereview.appspot.com/63060/diff/1/2 File Doc/library/zlib.rst (right):
http://codereview.appspot.com/63060/diff/1/2#newcode136 Line 136: When specified, it will cause the function's return value to be a (uncompressed, offset) how about this wording:
..."to be a tuple of (uncompressed, offset), with the"...
http://codereview.appspot.com/63060/diff/1/2#newcode142 Line 142: Added the offset argument missing . at the end of the sentence. Also, mention that this function now accepts keyword arguments.
http://codereview.appspot.com/63060/diff/1/3 File Lib/test/test_zlib.py (right):
http://codereview.appspot.com/63060/diff/1/3#newcode110 Line 110: c = zlib.compress(a)+zlib.compress(b) please surround the + with spaces for readability and consistency with other code in the file.\
http://codereview.appspot.com/63060/diff/1/4 File Modules/zlibmodule.c (right):
http://codereview.appspot.com/63060/diff/1/4#newcode193 Line 193: "the start position in the string to start decompresion and, if spceified,\n" typo: specified.
http://codereview.appspot.com/63060/diff/1/4#newcode296 Line 296: offset = length-zst.avail_in+offset; leave spaces around your - and + operators and this becomes easier to read.