(original) (raw)

I like the idea of a kind attribute, I don't like the current names for the possible values.

At the very least, "positional only" needs to be supported to handle nameless parameters in C functions (or those that unpack \*args internally)

The level of abbreviation used also seems unnecessary and internally inconsistent.

My proposal:
POSITIONAL- positional only
NAMED\_POSITIONAL - normal parameter
VAR\_POSITIONAL - \*args
KEYWORD - keyword only
VAR\_KEYWORDS - \*\*kwds

--
Sent from my phone, thus the relative brevity :)

On Jun 15, 2012 7:07 AM, "Ethan Furman" <ethan@stoneleaf.us> wrote:
Yury Selivanov wrote:
I'll amend the PEP this evening to replace 'is\_args', 'is\_kwargs',
and 'is\_keyword\_only' with a 'kind' attribute, with possible
values: 'positional', 'vararg', 'varkw', 'kwonly'.

Parameter class will have four constants, respectively:

� � class Parameter:
� � � � KIND\_POSITIONAL = 'positional'
� � � � KIND\_VARARG = 'vararg'
� � � � KIND\_VARKW = 'varkw'
� � � � KIND\_KWONLY = 'kwonly'

'Parameter.is\_implemented' will be renamed to 'Parameter.implemented'

Is everybody OK with this? �Thoughts?

I, for instance, like 'varkwarg' more than 'varkw' (+ it is more
consistent with \*\*kwargs)

+1

I like these names, and the similarity between 'vararg' and 'varkw'. �I would also be happy with 'args' and 'kwargs'.

\~Ethan\~
\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: http://mail.python.org/mailman/options/python-dev/ncoghlan%40gmail.com