It would be great if one could use "break for", "break while", "continue for" or "continue while". A silly example: for i in range(100): counter = 0 while 1+1 == 2: counter += 1 if counter > 5: break for "break for" should here jump out of the for-loop, as opposed to just "break" that would jump out of just the while loop. Using "break for" and friends will make code a lot more readable and explicit, and avoid using exception throwing and catching, and other acrobatics. I believe this suggestion is in sync with the Python Design guidelines.
Logged In: YES user_id=80475 Guido, I recommend against accepting these forms which are out of sync with the way the rest of the world uses break, continue, try, and except. The proposal is also thin on use cases and does not fit comfortably with the current implementation.
Logged In: YES user_id=6380 Rejected -- break and continue already have a goto-like flavor (you can easily write really inscrutable code using them) and this would just make it worse.