Issue 911176: move test() in SimpleDialog.py (original) (raw)
The test function in SimpleDialog is named "test()" instead of "_test()". Since it only is used to test the SimpleDialog class, at the very least it should be named "_test()" so it doesn't run the risk of overwriting a function by the same name when imported using "from SimpleDialog import *".
However, I propose that the function declaration for test () be moved under "if name == 'main':", that way the function is explicitly not part of the SimpleDialog module.