Message 81046 - Python tracker (original) (raw)

I agree that the names shouldn't clash with those in math, especially since it seems quite plausible that a user might want to use both itertools.combinations and math.combs (for example) in the same script.

No strong feelings about the actual names, but it would be nice if they somehow conveyed the idea of counting rather than enumerating. That is, if it weren't for the clearly ridiculous length, it would be nice to have:

itertools.combinations itertools.permutations

and

math.number_of_combinations math.number_of_permutations

etc.