Request for Review (Warning Cleanup java.io) (original) (raw)
Sebastian Sickelmann sebastian.sickelmann at gmx.de
Thu Dec 1 04:33:30 UTC 2011
- Previous message: 7116722: Miscellaneous warnings sun.misc ( and related classes )
- Next message: Request for Review of 7116890 (Warning Cleanup java.io)
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Hi,
i have a webrev[0] that contains some warning cleanup for java.io It is based on rev 7795c41ed54c http://hg.openjdk.java.net/jdk8/tl/jdk/
Some comments to the changes:
ExpiringCache.java: Changed anonymous inner class to inner class with the intention to put serialversion inside of it. But serialver doesn't want to give my the serialver. I also think that ExpiringCache is not serializable but the warning was clear: the anonymous inner class is seriallizable and has no explicit serialversionuid.
FilePermission.java: I have starred at the code between line 453 and 547 for over an hour, because i thought that there is a bug within the expression "i >= matchlen" in line 530 and the both "i != -1" in lines 457 and 461. But there is no bug. But i wanted to left this code slightly more readable. I introduced the method skipBeforePreviousComma to make it possible to work-around the fallthought warning with an return statement. This code-change need's some more review attention. Maybe we should split this up for another cleanup. I think the whole method needs some rewrite.
Some classes had no change at all. Maybe webrev created them because there where changes in my history/branches. There were some patches from alan i saw to late. Maybe webrev is confused of the multiple merges.
Can someone please create a CR for this and
- Previous message: 7116722: Miscellaneous warnings sun.misc ( and related classes )
- Next message: Request for Review of 7116890 (Warning Cleanup java.io)
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]