RFR: 8012665: CharSequence.chars, CharSequence.codePoints (original) (raw)
Paul Benedict pbenedict at apache.org
Thu Apr 25 20:57:41 UTC 2013
- Previous message: RFR: 8012665: CharSequence.chars, CharSequence.codePoints
- Next message: RFR: 8012665: CharSequence.chars, CharSequence.codePoints
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Henry,
I believe the coding standards require curly braces for any if-statement and for-loop.
Also the return statements exceed the 80 character limit. It would be nice to have them formatted across several lines like the following because it's difficult to read going straight across:
return StreamSupport.intStream(() -> Spliterators.spliterator( new CharIterator(), length(), Spliterator.ORDERED), Spliterator.SUBSIZED | Spliterator.SIZED | Spliterator.ORDERED);
Paul
- Previous message: RFR: 8012665: CharSequence.chars, CharSequence.codePoints
- Next message: RFR: 8012665: CharSequence.chars, CharSequence.codePoints
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]