[9] Review request: new macro for conversion to jboolean (original) (raw)

Anthony Petrov anthony.petrov at oracle.com
Mon Mar 17 18:31:54 UTC 2014


Personally, I'd call it to_jboolean(obj), but IS_TRUE(obj) sounds good to me too. Either way, I'm fine with the fix.

-- best regards, Anthony

On 3/17/2014 7:01 PM, Sergey Bylokhov wrote:

Hello. This review request is for the new macro, which simplify conversion to jboolean. It will be useful for fixing parfait warnings.

We have a lot of places, where we cast some type to jboolean: BOOL = retVal; return (jboolean) retVal; WARNING: Expecting value of JNI primitive type jboolean: mismatched value retVal with size 32 bits, retVal used for conversion to int8 in return

+++ b/src/share/native/common/jniutil.h Mon Mar 17 18:28:48 2014 +0400 @@ -277,6 +277,7 @@ #define ISNULL(obj) ((obj) == NULL) #define JNUIsNull(env,obj) ((obj) == NULL) +#define ISTRUE(obj) ((obj) ? JNITRUE : JNIFALSE) I am not sure about the name, probably someone have a better suggestion? The fix is for jdk9/dev. -- Best regards, Sergey.



More information about the core-libs-dev mailing list