Request for Review (XS): 7087445, Improve platform independence of JSR292 shared code (original) (raw)

John Rose john.r.rose at oracle.com
Tue Sep 6 16:38:05 PDT 2011


It's a little jarring to have initial_deoptimization_info supply the initial_fp of the unroll block.

I suggest s/initial_deoptimization_info/initial_fp_for_deoptimization/ to simplify the correspondence.

Then platforms which supply fp() for this don't have to apologize so much, and this line looks more normal:

info->set_initial_fp((intptr_t) array->sender().initial_fp_for_deoptimization());

-- John

On Sep 6, 2011, at 9:04 AM, Bertrand Delsart wrote:

Small shared changes necessary to improve portability of jsr292 on some platforms.

http://cr.openjdk.java.net/~bdelsart/7087445/webrev.00/ Should have no impact on the existing ports, as long as you add this backward compatible definition (added to SPARC, x86 and zero): intptrt *frame::initialdeoptimizationinfo() { return fp(); } Thanks, Bertrand. -- Bertrand Delsart, bertrand.delsart at oracle.com, Sun-Oracle France, 180 av. de l'Europe, ZIRST de Montbonnot, 38334 Saint Ismier, FRANCE



More information about the hotspot-compiler-dev mailing list