review for 7086585: make Java field injection more flexible (original) (raw)
Tom Rodriguez tom.rodriguez at oracle.com
Fri Sep 9 10:26:38 PDT 2011
- Previous message: review for 7086585: make Java field injection more flexible
- Next message: review for 7086585: make Java field injection more flexible
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
On Sep 9, 2011, at 10:21 AM, Vladimir Kozlov wrote:
Can we just have one class FieldDescriptor. Methods and fields are almost the same.
They serve different functions. RawFieldDescriptor hides and describes the layout of the fields array itself. fieldDescriptor serves as a self contained object for talking about a field. Think of it as a field handle. So they have to be separate types but they could be more closely related. Much of fieldDescriptor could be replaced by subclassing RawFieldDescriptor.
tom
Vladimir Tom Rodriguez wrote: I had a side conversion with Coleen about this and she suggested moving RawFieldDescriptor into it's own file, which I think is a good idea. She also commented on the confusion between RawFieldDescriptor and fieldDescriptor because of the name similarity. I had looked at making fieldDescriptor a subclass of RawField at one point and I think I might be able to make that work. I also think the RawFieldDescriptor name is bad. How about FieldLayout? Any opinions? I had also considered fixing the capitalization of fieldDescriptor. tom On Sep 8, 2011, at 3:47 PM, John Rose wrote:
I've reviewed it. It's excellent. Extra thanks for getting rid of instanceKlass::nextoffset. -- John
On Sep 8, 2011, at 1:38 PM, Tom Rodriguez wrote:
http://cr.openjdk.java.net/~never/7086585 1577 lines changed: 621 ins; 612 del; 344 mod; 65541 unchg
7086585: make Java field injection more flexible Reviewed-by:
- Previous message: review for 7086585: make Java field injection more flexible
- Next message: review for 7086585: make Java field injection more flexible
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
More information about the hotspot-compiler-dev mailing list