RFR (M): 8151126: Clean up duplicate code for clearing the mark bitmaps (original) (raw)

Tom Benson tom.benson at oracle.com
Tue Mar 8 19:20:41 UTC 2016


Hi, Looks good to me. One bit of trivia: Would you consider adding an assert that (cur == end) after the loop in doHeapRegion (code which you moved, but didn't change)? The loop assumes (end()-bottom()) is a multiple of M. Which is a good bet, of course. Tom

On 3/4/2016 2:41 PM, Thomas Schatzl wrote:

Hi all,

just noticed that I got the CR link wrong: it is https://bugs.openjdk.java.net/browse/JDK-8151126 of course. Thomas On Fri, 2016-03-04 at 11:20 +0100, Thomas Schatzl wrote: Hi all,

can I have reviews for this change that removes duplicate code for clearing the next mark bitmap. This duplication is in G1CMBitMap::clearAll() and G1ConcurrentMark::clearNextBitmap() for clearing the "next" bitmap which has been moved into G1ConcurrentMark::clearbitmap(). Most changes are moving the AbstractGangTask that is used for this around. There is JDK-8151171 to further clean up naming in the g1ConcurrentMark files. CR: https://bugs.openjdk.java.net/browse/JDK-8151171 Webrev: http://cr.openjdk.java.net/~tschatzl/8151126/webrev/ Testing: jprt, vm.gc testlist Thanks, Thomas



More information about the hotspot-gc-dev mailing list