RFR: 8199918: Shorten names of CollectedHeap::Name members (original) (raw)

Aleksey Shipilev shade at redhat.com
Wed Mar 21 09:19:54 UTC 2018


On 03/21/2018 09:09 AM, Per Liden wrote:

I propose that we shorten the member names in the CollectedHeap::Name enum. This is a pure cosmetic change. Essentially naming the GCs, rather than some of the CollectedHeap childen.

From: SerialHeap ParallelScavengeHeap G1CollectedHeap CMSHeap To: Serial Parallel CMS G1 This is a preparatory cleanup for JDK-8199925 and JDK-8199927. Bug: https://bugs.openjdk.java.net/browse/JDK-8199918 Webrev: http://cr.openjdk.java.net/~pliden/8199918/webrev.0

I like it very much.

Some assert messages are now outdated:

135 assert(heap->kind() == CollectedHeap::CMS, "Not a CMSHeap");

2485 assert(heap->kind() == CollectedHeap::G1, "Not a G1CollectedHeap");

625 assert(heap->kind() == CollectedHeap::Parallel, "Not a ParallelScavengeHeap");

1235 assert(heap->kind() == CollectedHeap::Serial || 1236 heap->kind() == CollectedHeap::CMS, "Not a GenCollectedHeap");

-Aleksey

-------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 819 bytes Desc: OpenPGP digital signature URL: <https://mail.openjdk.org/pipermail/hotspot-gc-dev/attachments/20180321/ddf55c6b/signature.asc>



More information about the hotspot-gc-dev mailing list