RFR: 8199927: Make WhiteBox more GC agnostic (original) (raw)
Aleksey Shipilev shade at redhat.com
Wed Mar 21 15:03:59 UTC 2018
- Previous message (by thread): RFR: 8199927: Make WhiteBox more GC agnostic
- Next message (by thread): RFR: 8199927: Make WhiteBox more GC agnostic
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
On 03/21/2018 03:50 PM, Per Liden wrote:
Updated webrev to reflect that GCSelector changed name to GCConfig in the patch for JDK-8199925.
Looks good to me.
This is a little dizzy, because I would have expected gc.isSelected() would tell me exactly what GC was being selected:
isAcceptable = gc.isSupported() && (gc.isSelected() || GC.isSelectedErgonomically());
...so it should be just:
for (GC gc : GC.values()) { map.put("vm.gc." + gc.name(), "" + gc.isSelected()); }
?
Thanks, -Aleksey
-------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 819 bytes Desc: OpenPGP digital signature URL: <https://mail.openjdk.org/pipermail/hotspot-gc-dev/attachments/20180321/7fc33191/signature.asc>
- Previous message (by thread): RFR: 8199927: Make WhiteBox more GC agnostic
- Next message (by thread): RFR: 8199927: Make WhiteBox more GC agnostic
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]