RFR: 8136978 Much nearly duplicated code for vmError support (original) (raw)
Sebastian Sickelmann sebastian.sickelmann at gmx.de
Thu Nov 19 10:46:32 UTC 2015
- Previous message: RFR: 8136978 Much nearly duplicated code for vmError support
- Next message: RFR: 8136978 Much nearly duplicated code for vmError support
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Hi Coleen,
thanks for finding those errors. I am sorry i missed those. It shows that it is really helpful two test/compile on multiple platforms. What is JPRT?
Please find the new webrev here:
http://cr.openjdk.java.net/~sebastian/8136978/webrev.02
thanks, Sebastian
On 11/19/2015 05:59 AM, Coleen Phillimore wrote:
Hi Sebastian, I tested your change through JPRT and there are a few changes I needed to make to get it to pass. One is that I changed os::messagebox to return bool since that's how it's used and the use in vmError.cpp made the Windows compiler complain. Others (hope you can read tell the diffs). There was thrsigsetmask on solaris and a couple places os::formatdebugmessage() you had 'p' rather than 'buf' and one place had 'buflen' rather than 80. Those places os::startdebugging(), it would be better to have sizeof(buf) rather than 80. Otherwise, Reviewed. If you do create a changeset, I will sponsor after another reviewer sees it. thanks, Coleen
< --- old/src/os/solaris/vm/ossolaris.cpp 2015-11-18_ _19:05:31.209186804 +0100_ _< +++ new/src/os/solaris/vm/ossolaris.cpp 2015-11-18_ _19:05:31.129186803 +0100_ _---_ _> diff --git a/src/os/solaris/vm/ossolaris.cpp b/src/os/solaris/vm/ossolaris.cpp > --- a/src/os/solaris/vm/ossolaris.cpp > +++ b/src/os/solaris/vm/ossolaris.cpp > @@ -3611,7 +3611,7 @@ > void os::printstatistics() { > } > > -int os::messagebox(const char* title, const char* message) { > +bool os::messagebox(const char* title, const char* message) { > int i; > fdStream err(defaultStream::errorfd()); > for (i = 0; i < 78; i++) err.printraw("=");_ _195c239_ _< + return sigsetmask(SIGUNBLOCK, set, NULL);_ _---_ _> + return thrsigsetmask(SIGUNBLOCK, set, NULL); 199c243 < + jiosnprintf(p, buflen,_ _---_ _> + jiosnprintf(buf, buflen, 210c254 < + jiosnprintf(buf, buflen, "dbx - %d", os::currentprocessid());_ _---_ _> + jiosnprintf(buf, 80, "dbx - %d", os::currentprocessid()); < --- old/src/os/windows/vm/oswindows.cpp 2015-11-18_ _19:05:31.977186818 +0100_ _< +++ new/src/os/windows/vm/oswindows.cpp 2015-11-18_ _19:05:31.829186815 +0100_ _---_ _> diff --git a/src/os/windows/vm/oswindows.cpp b/src/os/windows/vm/oswindows.cpp > --- a/src/os/windows/vm/oswindows.cpp > +++ b/src/os/windows/vm/oswindows.cpp > @@ -4005,7 +4005,7 @@ > } > > > -int os::messagebox(const char* title, const char* message) { > +bool os::messagebox(const char* title, const char* message) { > int result = MessageBox(NULL, message, title, > MBYESNO | MBICONERROR | MBSYSTEMMODAL | MBDEFAULTDESKTOPONLY); > return result == IDYES; 230a286 > - 232c288 < + jiosnprintf(p, buflen,_ _---_ _> + jiosnprintf(buf, buflen,
On 11/18/15 1:15 PM, Sebastian Sickelmann wrote: Hi, Coleen found some places where I missed some refactoring due to the rebase of the initial patch. Thanks for reporting it to me. I hope this here is fine now on every platform: http://cr.openjdk.java.net/~sebastian/8136978/webrev.02/ Sorry for the inconvenience. -- Sebastian
- Previous message: RFR: 8136978 Much nearly duplicated code for vmError support
- Next message: RFR: 8136978 Much nearly duplicated code for vmError support
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]