RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp (original) (raw)
Ioi Lam ioi.lam at oracle.com
Thu Oct 4 15:51:10 UTC 2018
- Previous message: RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp
- Next message: RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Hi Jiangli,
The fix looks good.
#if INCLUDE_CDS_JAVA_HEAP // The mirrors are NULL if HeapShared::is_heap_object_archiving_allowed // is false. f->do_oop(&_int_mirror); f->do_oop(&_float_mirror);
Maybe the comment should be turned into an assert?
Also, have you tested with configure --disable-precompiled-headers?
Thanks
- Ioi
On 10/3/18 3:23 PM, Jiangli Zhou wrote:
Please review the restructuring and cleanup of java heap object archiving code. The java object archiving code has grown in the past year and metaspaceShared.* files are not the suitable place. The restructuring and cleanup include:
- Moved java heap object archiving implementation from metaspaceShared.* to heapShared.*. - Various isarchiveobject() APIs are renamed to isarchivedobject() for naming consistency: - Renamed MetaspaceShared::isarchiveobject() to HeapShared::isarchivedobject(). - Renamed oopDesc::isarchiveobject() to oopDesc::isarchivedobject(). - Renamed G1ArchiveAllocator::isarchiveobject() to G1ArchiveAllocator::isarchivedobject(). - Changed to use G1ArchiveAllocator::isarchivedobject() in G1CollectedHeap::materializearchivedobject(). Removed #include "memory/metaspaceShared.inline.hpp” from g1CollectedHeap.cpp. - Renamed HeapShared::archivestaticfields() to HeapShared::archiveobjectsubgraphs(). webrev: http://cr.openjdk.java.net/~jiangli/8206009/webrev.00/ RFE: https://bugs.openjdk.java.net/browse/JDK-8206009 Tested with tier1-tier3. Tier4 and tier5 are in progress. Thanks, Jiangli
- Previous message: RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp
- Next message: RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]