RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp (original) (raw)
Jiangli Zhou jiangli.zhou at oracle.com
Thu Oct 4 22:50:08 UTC 2018
- Previous message: RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp
- Next message: RFR(M): 8204908: NVDIMM for POGC and G1GC - ReserveSpace.cpp changes are mostly eliminated/no collector specific code.
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Hi Coleen,
Thanks for the review! I've fixed to use oopDesc::equals as you suggested:
updated webrev: http://cr.openjdk.java.net/~jiangli/8206009/webrev.01/src/hotspot/share/memory/heapShared.hpp.frames.html
Thanks,
Jiangli
On 10/4/18 2:48 PM, coleen.phillimore at oracle.com wrote:
+ static bool oopequals(oop const& p1, oop const& p2) { + return p1 == p2; + } You may need to use oopDesc::equals or the Access API to compare the oops to not run afoul of shenandoah here. It's apparently not needed for the comparisons to zero that I also saw. The separation looks really good! Coleen On 10/3/18 6:23 PM, Jiangli Zhou wrote: Please review the restructuring and cleanup of java heap object archiving code. The java object archiving code has grown in the past year and metaspaceShared.* files are not the suitable place. The restructuring and cleanup include:
- Moved java heap object archiving implementation from metaspaceShared.* to heapShared.*. - Various isarchiveobject() APIs are renamed to isarchivedobject() for naming consistency: - Renamed MetaspaceShared::isarchiveobject() to HeapShared::isarchivedobject(). - Renamed oopDesc::isarchiveobject() to oopDesc::isarchivedobject(). - Renamed G1ArchiveAllocator::isarchiveobject() to G1ArchiveAllocator::isarchivedobject(). - Changed to use G1ArchiveAllocator::isarchivedobject() in G1CollectedHeap::materializearchivedobject(). Removed #include "memory/metaspaceShared.inline.hpp” from g1CollectedHeap.cpp. - Renamed HeapShared::archivestaticfields() to HeapShared::archiveobjectsubgraphs(). webrev: http://cr.openjdk.java.net/~jiangli/8206009/webrev.00/ RFE: https://bugs.openjdk.java.net/browse/JDK-8206009 Tested with tier1-tier3. Tier4 and tier5 are in progress. Thanks, Jiangli
- Previous message: RFR:8206009: Move java heap object archiving code to heapShared.hpp and heapShared.cpp
- Next message: RFR(M): 8204908: NVDIMM for POGC and G1GC - ReserveSpace.cpp changes are mostly eliminated/no collector specific code.
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]