Fwd: hg: lambda/lambda/jdk: Replace explode() with two forms of flatMap: flatMap(T->Stream), and flatMap(FlatMapper<T, U>) (original) (raw)

Brian Goetz brian.goetz at oracle.com
Thu Feb 7 11:53:30 PST 2013


I pushed an update along the lines of what was discussed yesterday, so people can take a look. Summary:

Check it out and see what you think. Commit message attached. I think this is an improvement.

Bikeshedding on naming can continue :)

-------- Original Message -------- Subject: hg: lambda/lambda/jdk: Replace explode() with two forms of flatMap: flatMap(T->Stream), and flatMap(FlatMapper<T, U>) Date: Thu, 07 Feb 2013 19:37:14 +0000 From: brian.goetz at oracle.com To: lambda-dev at openjdk.java.net

Changeset: 3aed6b4f4d42 Author: briangoetz Date: 2013-02-07 14:36 -0500 URL: http://hg.openjdk.java.net/lambda/lambda/jdk/rev/3aed6b4f4d42

Replace explode() with two forms of flatMap: flatMap(T->Stream), and flatMap(FlatMapper<T,U>)

! src/share/classes/java/util/stream/DoublePipeline.java ! src/share/classes/java/util/stream/DoubleStream.java



More information about the lambda-libs-spec-observers mailing list