A few very minor library issues (original) (raw)

Kevin Bourrillion kevinb at google.com
Fri Feb 22 08:06:17 PST 2013


Just a few little things.

  1. I feel the Stream methods findFirst() and findAny() can really be named just first() and any(). The "find" is just odd and doesn't do enough. Failing that, I'd go for firstElement() / anyElement().

  2. I like Stream.substream(), but Stream.subStream() is undeniably consistent with the collections API (subSet, etc.; sure, String.substring() doesn't follow that, but it's "farther away"). I'm actually on the fence here, because I think "substream" is strictly the correct way to camel-case the word "substream"...

  3. Are we concerned that the name Map.computeIfAbsent() obscures what the mutative effect on the map is?

-- Kevin Bourrillion | Java Librarian | Google, Inc. | kevinb at google.com



More information about the lambda-libs-spec-observers mailing list