Function type naming conventions (original) (raw)

Brian Goetz brian.goetz at oracle.com
Thu Jan 3 11🔞33 PST 2013


Why not be plainer about it and use FromIntFunction. People will catch on that the other one, IntFunction means ToIntFunction.

Note that IntFunction only means ToIntFunction for SAMs where the return is generic. Otherwise it means FromIntBlock. The rule we've got now specializes type parameters in order, but pretending that the return position (if generic) is first.

Or you could redo that side of the naming pattern as FunctionToInt etc? (Although probably not all the way to renaming IntOperator as FromIntFunctionToInt...)

I played with that at first, and wasn't thrilled about how it scaled to to multiple arguments or non-Function bases:

BiBlockFromTInt / FromTIntBiBlock

vs the proposed

TIntBiBlock

which seemed more consistent with what we had so far?



More information about the lambda-libs-spec-observers mailing list