Function type naming conventions (original) (raw)
Doug Lea dl at cs.oswego.edu
Thu Jan 3 12:46:33 PST 2013
- Previous message: Function type naming conventions
- Next message: Function type naming conventions
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
On 01/03/13 15:25, Brian Goetz wrote:
OK, forget I said the second part about generalizing this. I still think "FromIntFunction" is less cringe-y than hiding the "T" in the middle of "IntTFunction" :-) If it is the T that makes you cringe, we can use Obj: IntObjFunction
Which is getting pretty close to my initial suggested scheme of IntToObject (why bother with the word "function" here?) that everyone hated?
And of course, if you do this, then you'd naturally do "ObjectToInt" etc.
But given that no naming scheme is good in any absolute sense, even IntTFunction is probably something people could learn to live with.
-Doug
- Previous message: Function type naming conventions
- Next message: Function type naming conventions
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
More information about the lambda-libs-spec-observers mailing list