mappedTo -> join? (original) (raw)

Brian Goetz brian.goetz at oracle.com
Tue Jan 8 09:12:04 PST 2013


One of the reducers we've got takes a Stream and a function T->U and creates a Map<T,U>. Currently we call this "mappedTo". Should this be called "join" instead? Or mapJoin?

Map<Person, Integer> map = people.reduce(mappedTo(Person::getAge))); vs Map<Person, Integer> map = people.reduce(join(Person::getAge))); Map<Person, Integer> map = people.reduce(mapJoin(Person::getAge)));



More information about the lambda-libs-spec-observers mailing list