Code review request: 7197245: Eliminate sun.security.ssl.JsseJce dependency on sun.security.ec (original) (raw)

Michael StJohns mstjohns at comcast.net
Tue Sep 11 17:06:16 UTC 2012


There's a number of places where Arrays.copyOfRange might be a better choice than System.arraycopy and the various array creations - if only for readability.

Also, instead of the function trimZeroes, how about instead a "static byte getMagnitude (BigInteger val, int magSize)" method which is really what you're trying to do. Still throw the RuntimeError, but do it inside that method. This is a method I really wish were part of BigInteger.

Mike

Sent from my iPad

On Sep 11, 2012, at 12:22, Vincent Ryan <vincent.x.ryan at oracle.com> wrote:

Hello Brad, Please review these changes to eliminate the dependency between the SunJSSE provider and the ECParameters and NamedCurve classes in the SunEC provider. http://cr.openjdk.java.net/~vinnie/7197245/webrev.00/ Thanks.



More information about the security-dev mailing list