[Python-Dev] Currently baking idea for dict.sequpdate(iterable, value=True) (original) (raw)

Guido van Rossum guido@python.org
Mon, 25 Nov 2002 11:32:34 -0500


> x = {}.sequpdate(...) > > which suggests that you're really looking for a different constructor > as a class method.

Yes! Will revise the patch accordingly and use Just's suggested name, fromseq(). Do you prefer the default value to be None or True? Earlier discussions on python-dev showed that True is more meaningful to some in the context of membership testing. OTOH, dict.setvalue and dict.get both use None.

I think it should be None -- let's be explicit when we want True.

--Guido van Rossum (home page: http://www.python.org/~guido/)