[Python-Dev] Path PEP: some comments (original) (raw)

Andy Teijelo Pérez ateijelo at uh.cu
Wed Feb 8 17:10:45 CET 2006


El Sábado, 4 de Febrero de 2006 2:35, Giovanni Bajo escribió:

Hello,

my comments on the Path PEP: - Many methods contain the word 'path' in them. I suppose this is to help transition from the old library to the new library. But in the context of a new Python user, I don't think that Path.abspath() is optimal. Path.abs() looks better. Maybe it's not so fundamental to have exactly the same names of the old library, especially when thinking of future? If I rearrange my code to use Path, I can as well rename methods to something more sound at the same time. I haven't revised the whole class to look exactly which methods contain the word path and which do not. But, anyway this is just a simple comment. It's clear to me that Path.abspath() look redundant and Path.abs() tells clearly what the method does. But I think in most cases the method won't be used through the class, like 'Path.abs(instance)' but through an existing instance like 'home.abs()'. In this case, I think 'home.abspath()' would be more readable than 'home.abs()'. Anyway, in the long term, I think people will just get used to what gets finally decided, so I could say I'm +0 about this. (Does one have to be a python developer or something to use the {+,-}{0,1} thing?, 'cause I'm not.)

Regards, Andy.



More information about the Python-Dev mailing list