[Python-Dev] PEP 358 (bytes type) comments (original) (raw)
Brett Cannon brett at python.org
Wed Feb 22 22:22:19 CET 2006
- Previous message: [Python-Dev] defaultdict and on_missing()
- Next message: [Python-Dev] PEP 358 (bytes type) comments
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
First off, thanks to Neil for writing this all down. The whole thread of discussion on the bytes type was rather long and thus hard to follow. Nice to finally have it written down in a PEP.
Anyway, a few comments on the PEP. One, should the hex() method instead be an attribute, implemented as a property? Seems like static data that is entirely based on the value of the bytes object and thus is not properly represented by a method.
Next, why are the *slice methods to be defined? Docs say they are deprecated.
And for the open-ended questions, I don't think sort() is needed.
Lastly, maybe I am just dense, but it took me a second to realize that it will most likely return the ASCII string for str() for use in something like socket.send(), but it isn't explicitly stated anywhere. There is a chance someone might think that str will somehow return the sequence of integers as a string does exist.
-Brett
- Previous message: [Python-Dev] defaultdict and on_missing()
- Next message: [Python-Dev] PEP 358 (bytes type) comments
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]