[Python-Dev] The path module PEP (original) (raw)
Gustavo J. A. M. Carneiro gjc at inescporto.pt
Tue Jan 24 22:34:28 CET 2006
- Previous message: [Python-Dev] The path module PEP
- Next message: [Python-Dev] The path module PEP
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
On Tue, 2006-01-24 at 21:22 +0100, BJörn Lindqvist wrote: [...]
# Operations on path strings. def abspath(sef): ... def normcase(self): ... def normpath(self): ... def realpath(self): ... def expanduser(self): ... def expandvars(self): ... def dirname(self): ... def basename(self): ... def expand(self): ... def splitpath(self): ... def splitdrive(self): ... def splitext(self): ... def stripext(self): ... def splitunc(self): ... [1] def joinpath(self, *args): ... def splitall(self): ... def relpath(self): ... def relpathto(self, dest): ... [...etc...]
If we wanted to take PEP 8 seriously, those method names should be changed to words_separated_by_underscores.
And BTW, what does splitunc do? It really should have a more descriptive name.
Regards.
-- Gustavo J. A. M. Carneiro <gjc at inescporto.pt> <gustavo at users.sourceforge.net> The universe is always one step beyond logic
- Previous message: [Python-Dev] The path module PEP
- Next message: [Python-Dev] The path module PEP
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]