[Python-Dev] Proposed unittest changes (original) (raw)
Christian Heimes lists at cheimes.de
Thu Apr 17 17:27:19 CEST 2008
- Previous message: [Python-Dev] Proposed unittest changes
- Next message: [Python-Dev] Proposed unittest changes
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Michael Foord schrieb:
By etc I assume you mean:
assertLessThan assertGreaterThan assertLessThanOrEquals assertGreaterThanOrEquals Would not variants be useful as well - it seems not as the not of one is always another... (I think 'assertLessThan' reads better than 'assertLess' but will do what I'm told...)
Most of the etc. could be simplified with a function assertOp which takes an operator as first argument
import operator def assertOp(self, op, a, b, msg): func = getattr(operator, op) self.assert_(func(a, b) ...)
assertOp("gt", a, b) == assert a > g
I also like to have some assert for is, type, isinstance, issubclass and contains.
Christian
- Previous message: [Python-Dev] Proposed unittest changes
- Next message: [Python-Dev] Proposed unittest changes
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]