[Python-Dev] A couple of PEP 418 comments (original) (raw)
Antoine Pitrou solipsis at pitrou.net
Fri Apr 13 15:38:39 CEST 2012
- Previous message: [Python-Dev] Fwd: Error in MD5 checksums of the 2.7.3 release page.
- Next message: [Python-Dev] A couple of PEP 418 comments
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Hello,
I'm just starting a new thread since the old ones are so crowded. First, overall I think the PEP is starting to look really good and insightful! (congratulations to Victor)
I have a couple of comments, mostly small ones:
"function" (str): name of the underlying operating system function.
I think "implementation" is a better name here (more precise, and perhaps also more accurate :-)).
time.monotonic() time.perfcounter() time.processtime()
The descriptions should really stress the scope of the result's validity. My guess (or wish :-)) would be:
- time.monotonic(): system-wide results, comparable from one process to another
- time.perf_counter(): process-wide results, comparable from one thread to another (?)
- time.process_time(): process-wide, by definition
It would also be nice to know if some systems may be unable to implement time.monotonic().
GetTickCount() has an precision of 55 ms on Windows 9x.
Do we care? :) Precision under recent Windows variants (XP or later) would be more useful.
Is there a designated dictator for this PEP?
Regards
Antoine.
- Previous message: [Python-Dev] Fwd: Error in MD5 checksums of the 2.7.3 release page.
- Next message: [Python-Dev] A couple of PEP 418 comments
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]