I guess a bikeshed question is whether it should be `os.pidfd_send_signal` (like `os.kill`) or `signal.pidfd_send_signal` (like `signal.pthread_kill`). I don't actually care either way myself :-)
Yes, I thought about that a bit. I choose signal because: 1. signal already has some specialized functions that send signals pthread_kill and raise_signal. 2. If we every do want to implement the third parameter of pidfd_send_signal, the signal module already defines a siginfo structseq. 3. (least convincing) os/posix has way too much stuff. I generally think that we should strive to find a good home for new OS-level functionality that isn't the os module.