disklabel(8) - OpenBSD manual pages (original) (raw)
DISKLABEL(8) OpenBSD System Manager's Manual DISKLABEL(8)
NAME disklabel - read and write disk pack label
SYNOPSIS disklabel [-n] [-cd | -r] [-t] [-v] disk disklabel -w [-n] [-cd | -r] [-v] disk disktype [packid] disklabel -e [-n] [-cd | -r] [-v] disk disklabel -E [-f tempfile] [-n] [-cd | -r] [-v] disk disklabel -R [-r] [-n] [-v] disk protofile disklabel [-NW] [-n] [-v] disk
**disklabel** **-B** [**-n**] [**-v**] [**-b** _boot1_ [**-s** _boot2_]] _disk_ [_disktype_]
**disklabel** **-w** **-B** [**-n**] [**-v**] [**-b** _boot1_ [**-s** _boot2_]] _disk_ _disktype_ [_packid_]
**disklabel** **-R** **-B** [**-n**] [**-v**] [**-b** _boot1_ [**-s** _boot2_]] _disk_ _protofile_ [_disktype_]
DESCRIPTION The disklabel utility can be used to install, examine, or modify the la- bel on a disk drive or pack. The disk label contains information about disk characteristics (size, type, etc.) and the partition layout, stored on the disk itself. It is used by the operating system to optimize disk I/O and locate the filesystems resident on the disk.
The options are as follows:
**-n** Make no permanent changes to the disklabel (useful for debugging
purposes).
**-v** Print additional information during operation (verbose mode).
**-r** Causes the label to be read from or written to the disk directly,
rather than going through the system's in-core copy of the label.
This option may allow a label to be installed on a disk without
kernel support for a label, such as when labels are first in-
stalled on a system. This flag does not work on a number of ar-
chitectures, thus it is not considered the right way to put a new
label on a disk. Its use is discouraged.
**-B** Install bootstrap code. The **-r** flag is implied by **-B** and never
needs to be specified.
**-b** Specify the single level boot program, or the primary boot pro-
gram, depending on the system boot architecture (single or two-
level).
**-s** On machines with a two-level bootstrap (such as i386-based sys-
tems), specify the secondary boot program.
**-d** Use the _default_ label. This ignores any existing OpenBSD parti-
tions on the disk. Note that this option will only work for
disks that are capable of reporting their geometry, such as SCSI,
IDE, and ESDI. May not be used in conjunction with the **-r** flag.
**-c** Clear the system's in-core copy of the label and update it based
on the on-disk label. May not be used in conjunction with the **-r**
flag.
**-f** _tempfile_
Write entries to _tempfile_ in fstab(5) format for any partitions
for which mount point information has been specified. The **-f**
flag is only valid when used in conjunction with the **-E** flag. If
_tempfile_ already exists, it will be overwritten.
**-t** Format the label as a disktab(5) entry.
**-w** Write a standard label on the designated drive.
**-e** Edit an existing disk label using the editor specified in the
EDITOR environment variable, or vi(1) if none is specified.
**-E** Use a simple initial label editor, using the command-driven
built-in editor described below.
**-R** Restore a disk label that was formatted in a prior operation and
saved in an ASCII file.
**-N** Disallow writing of the pack label area on the selected disk.
**-W** Allow writing of the pack label area on the selected disk.
The first form of the command (read) is used to examine the label on the
named disk drive (e.g., sd0 or _/dev/rsd0c_). It will display all of the
parameters associated with the drive and its partition layout. Unless
the **-r** flag is given, the kernel's in-core copy of the label is dis-
played; if the disk has no label, or the partition types on the disk are
incorrect, the kernel may have constructed or modified the label.
The second form of the command (write) is used to write a standard label
on the designated drive. The drive parameters and partitions are taken
from that file. If different disks of the same physical type are to have
different partitions, it will be necessary to have separate disktab en-
tries describing each, or to edit the label after installation as de-
scribed below. The optional argument is a pack identification string, up
to 16 characters long. The pack ID must be quoted if it contains blanks.
If the **-r** flag is given, the disk sectors containing the label and boot-
strap will be written directly. A side-effect of this is that any exist-
ing bootstrap code will be overwritten and the disk rendered unbootable.
If **-r** is not specified, the existing label will be updated via the in-
core copy and any bootstrap code will be unaffected. If the disk does
not already have a label, the **-r** flag must be used. In either case, the
kernel's in-core label is replaced.
In the third form of the command (edit), the label is read from the in-
core kernel copy, or directly from the disk if the **-r** flag is also given.
The label is formatted and then supplied to an editor for changes. If no
editor is specified in an EDITOR environment variable, vi(1) is used.
When the editor terminates, the formatted label is reread and used to
rewrite the disk label. Existing bootstrap code is unchanged regardless
of whether **-r** was specified.
The initial label editor mode is only intended for new disks as it will
move partitions around as necessary to maintain a contiguous pool of free
blocks. Some commands or prompts take an optional unit. Available units
are `b' for bytes, `c' for cylinders, `k' for kilobytes, `m' for
megabytes, and `g' for gigabytes. Quantities will be rounded to the
nearest cylinder when units are specified for sizes (or offsets). Com-
mands may be aborted by entering `^D' (Control-D). Entering `^D' at the
main `>' prompt will exit the editor. At prompts that request a size,
`*' may be entered to indicate the rest of the available space. The edi-
tor commands are as follows:
? [command]
Display help message with all available commands. You may
specify a _command_ for which to get more detailed help. There
is also (simple) context-sensitive help available at most
prompts.
M Display this manual page.
u Undo (or redo) last change. Entering _u_ once will undo your
last change. Entering it again will restore the change.
p [unit] Print the current disk label. If a _unit_ is given, the size
and offsets are displayed in terms of the specified unit.
e Edit drive parameters. This option is used to set the follow-
ing parameters: sectors/track, tracks/cylinder, sectors/cylin-
der, number of cylinders on the disk, total sectors on the
disk, rpm, interleave, disk type, and a descriptive label
string.
b Set OpenBSD disk boundaries. This option tells **disklabel**
which parts of the disk it is allowed to modify. This option
is probably only useful for ports with fdisk partition tables
where the ending sector in the MBR is incorrect. The user may
enter `*' at the ``Size'' prompt to indicate the entire size
of the disk (minus the starting sector). This is useful for
disks larger than 8 gigabytes where the fdisk partition table
is incapable of storing the real size.
r Recalculate free space. This option should really not be nec-
essary under normal circumstances.
a [part] Add new partition. This option adds a new BSD partition. If
no partition letter is specified (a-p), the user will be
prompted for one.
c [part] Change the size of an existing partition. If no partition is
specified, the user will be prompted for one. The new size
may be in terms of the aforementioned units and may also be
prefixed with `+' or `-' to change the size by a relative
amount.
d [part] Delete an existing partition (or `*' to delete all parti-
tions). If no partition is specified, the user will be
prompted for one. You may not delete the `c' partition.
g [d|b|u] Set disk geometry based on what the _disk_, _BIOS_, or _user_ thinks
(the _user_ geometry is simply what the label said before
**disklabel** made any changes).
D Sets the disk label to the default values as reported by the
kernel. This similates the case where there is no disk label.
m [part] Modify parameters for an existing partition. If no partition
is specified, the user will be prompted for one. This option
allows the user to change the filesystem type, starting off-
set, partition size, block fragment size, block size, and
cylinders per group for the specified partition (not all pa-
rameters are configurable for non-BSD partitions).
n [part] Name the mount point for an existing partition. If no parti-
tion is specified, the user will be prompted for one. This
option is only valid if **disklabel** was invoked with the **-f**
flag.
s [path] Save the label to a file in ASCII format (suitable for loading
via the **-R** option). If no path is specified, the user will be
prompted for one.
w Write the label to disk. This option will commit any changes
to the on-disk label.
q Quit the editor. If any changes have been made, the user will
be asked whether or not to save the changes to the on-disk la-
bel.
x Exit the editor without saving any changes to the label.
X Toggle ``expert mode''. By default, some settings are reserved
for experts only (such as the block and fragment size on ffs
partitions).
z Zeroes out the existing partition table, leaving only the
``c'' partition. The drive parameters are not changed.
In the restore form of the command, the prototype file used to create the
label should be in the same format as that produced when reading or edit-
ing a label. Comments are delimited by _#_ and newline. As with **-w**, any
existing bootstrap code will be clobbered if **-r** is specified and will be
unaffected otherwise.
The final three forms of **disklabel** are used to install bootstrap code on
machines where the bootstrap is part of the label. The bootstrap code is
comprised of one or two boot programs depending on the machine.
When installting bootstrap code with the **-B** flag, if the names are not
explicitly given, standard boot programs will be used. The boot programs
are located in _/usr/mdec_. The names of the programs are taken from the
``b0'' and ``b1'' parameters of the disktab(5) entry for the disk if
_disktype_ was given and its disktab entry exists and includes those param-
eters. Otherwise, boot program names are derived from the name of the
disk. These names are of the form _basename_boot for the primary (or only)
bootstrap, and boot_basename_ for the secondary bootstrap; for example,
_/usr/mdec/sdboot_ and _/usr/mdec/bootsd_ if the disk device is _sd0_.
The first of the three boot-installation forms is used to install boot-
strap code without changing the existing label. It is essentially a read
command with respect to the disk label itself and all options are related
to the specification of the boot program as described previously. The
final two forms are analogous to the basic write and restore versions ex-
cept that they will install bootstrap code in addition to a new label.
EXAMPLES disklabel sd0
Display the in-core label for sd0 as obtained via _/dev/rsd0c_.
disklabel -w -r /dev/rsd0c sd2212 foo
Create a label for sd0 based on information for ``sd2212'' found in
_/etc/disktab_. Any existing bootstrap code will be clobbered. (Normally
you do not want to use the **-r** flag though.)
disklabel -e -r sd0
Read the on-disk label for sd0, edit it and reinstall in-core as well as
on-disk. (Normally you do not want to use the **-r** flag though.) Existing
bootstrap code is unaffected.
disklabel -R sd0 mylabel
Restore the on-disk and in-core label for sd0 from information in
_mylabel_. Existing bootstrap code is unaffected.
disklabel -B sd0
Install a new bootstrap on sd0. The boot code comes from
_/usr/mdec/sdboot_ and possibly _/usr/mdec/bootsd_. On-disk and in-core la-
bels are unchanged, but on some systems other information may be de-
stroyed. Use with care.
disklabel -w -B /dev/rsd0c -b newboot sd2212
Install a new label and bootstrap. The label is derived from disktab in-
formation for ``sd2212'' and installed both in-core and on-disk. The
bootstrap code comes from the file _/usr/mdec/newboot_.
FILES /etc/disktab /usr/mdec/xx_boot /usr/mdec/boot_xx
SEE ALSO disklabel(5), disktab(5), scan_ffs(5)
DIAGNOSTICS
The kernel device drivers will not allow the size of a disk partition to
be decreased or the offset of a partition to be changed while it is open.
Some device drivers create a label containing only a single large parti-
tion if a disk is unlabeled; thus, the label must be written to the a' partition of the disk while it is open. This sometimes requires the de- sired label to be set in two steps, the first one creating at least one other partition, and the second setting the label on the new partition while shrinking the
a' partition.
On some machines the bootstrap code may not fit entirely in the area al-
located for it by some filesystems. As a result, it may not be possible
to have filesystems on some partitions of a ``bootable'' disk. When in-
stalling bootstrap code, **disklabel** checks for these cases. If the in-
stalled boot code would overlap a partition of type FS_UNUSED it is
marked as type FS_BOOT. The newfs(8) utility will disallow creation of
filesystems on FS_BOOT partitions. Conversely, if a partition has a type
other than FS_UNUSED or FS_BOOT, **disklabel** will not install bootstrap
code that overlaps it.
NOTES On i386 machines, installboot(8) is normally used to install boot code. The -B option to disklabel can still be used to install old style boot code, but this usage is deprecated.
On some machines, such as the sparc and amiga, partition tables may not
exhibit the full functionality that is described above.
BUGS
When a disk name is given without a full pathname, the constructed device
name uses the a' partition on the tahoe, the
c' partition on all oth-
ers. In -E mode, disklabel is far too quick to shuffle partitions
around; it should keep a free block list and only move partitions around
with the user's permission. Also, in -E mode, partitions outside the
OpenBSD portion of the disk should be changeable.
OpenBSD 2.9 October 27, 1997 5