Message 188775 - Python tracker (original) (raw)

I agree it should work the same as Enum, and I agree it should be possible to supply the module name. But wouldn't it be cleaner as:

Point = namedtuple('Point', 'x y z', module=name)

rather than:

Point = namedtuple(name + '.Point', 'x y z')

?