Message 300477 - Python tracker (original) (raw)
Slight amendment: __delegated_to__
and __returns_to__
might be better names for the doubly-linked list of the async call chain.
"async_call" and "async_return" both have the problem that they look like imperative commands (since "call" and "return" are typically used as verbs), and collection referring to "yield from" and "await" as "asynchronous delegation" would help avoid potential confusion with regular synchronous function calls.
I've also retitled the issue to cover the broader scope that also addresses the needs of the inspect module, not just the dis module.