JDK 8 Installation on the Oracle Solaris Operating System (original) (raw)
This page describes several ways to install the JDK on Oracle Solaris.
This page has these topics:
- "System Requirements"
- "Installation Instructions Notation"
- "JDK 8 Installation Instructions for Oracle Solaris 11 using IPS packages"
- "Manual JDK 8 Installation Instructions"
- "Selecting the Default Java Platform"
See "JDK 8 and JRE 8 Installation Start Here" for general information about installing JDK 8 and JRE 8.
For information on enhancements to JDK 8 that relate to the installer, see "Installer Enhancements in JDK 8".
Installation Instructions Notation
For any text on this page containing the following notation, you must substitute the appropriate JDK update version number for the notation.
version
For example, if you are installing update JDK 8 update release 1, the following string representing the name of the bundle:
jdk-8u_version_-solaris-sparc.tar.gz
becomes:
jdk-8u1-solaris-sparc.tar.gz
Note that, as in the preceding example, the version
number is sometimes preceded with the letter u
, for example, 8u1
, and sometimes it is preceded with an underscore, for example, jdk1.8.0_01
.
JDK 8 Installation Instructions for Oracle Solaris 11 using IPS packages
To install JDK 8 on Oracle Solaris 11, install the jdk-8
package:
- Make sure the
jdk-8
package is available from your IPS publisher.
$ pkg list -a jdk-8
NAME (PUBLISHER) VERSION IFO
developer/java/jdk-8 1.8.0.0-0.183.0.0.0.0.0 ---
If you see an "i" in the I column, then the package is already installed.
This package is available from thesolaris
publisher atpkg.oracle.com
and also from other publisher origins. If you see a message that no such package is found, use thepkg
publisher
command to check your publisher origin and contact your system administrator or Oracle Support representative. - Make sure you have permission to install IPS packages.
- Use the profiles command to list the rights profiles that are assigned to you. If you have the Software Installation rights profile, you can use the
pfexec
command to install and update packages.
$ pfexec pkg install jdk-8
Other rights profiles also provide installation privilege, such as System Administrator rights profile. - Depending on the security policy at your site, you might be able to use the
sudo
command with your user password to execute a privileged command.
$ sudo pkg install jdk-8 - Use the
roles
command to list the roles that are assigned to you. If you have the root role, you can use thesu
command with the root password to assume the root role.
pkg install jdk-8
- Use the profiles command to list the rights profiles that are assigned to you. If you have the Software Installation rights profile, you can use the
Manual JDK 8 Installation Instructions
The following table lists the options available for downloading the JDK 8 release on the Oracle Solaris platform.
Download File(s) | Architecture | Who Can Install |
---|---|---|
jdk-8uversion-solaris-sparcv9.tar.gz | 64-bit SPARC | anyone |
jdk-8uversion-solaris-x64.tar.gz | 64-bit x64, EM64T | anyone |
jdk-8uversion-solaris-sparcv9.tar.Z | 64-bit SPARC | root |
jdk-8uversion-solaris-x64.tar.Z | 64-bit x64, EM64T | root |
Installation instructions are by file type:
.tar.gz
files: See "Installation of Oracle Solaris Archive Binaries (.tar.gz)". This technique allows you to install a private version of the JDK for the current user into any location, without affecting other JDK installations. However, it may involve manual steps to get some of the features to work (for example, the-version:
release
option of thejava
command which allows you to specify the release to be used to run the specified class requires the correct path to the JDK release under/usr/jdk
)..tar.Z
files: See "Installation of Oracle Solaris SVR4 Packages (.tar.Z)". This technique allows you to perform a system-wide installation of the JDK for all users, and requires root access. Note that this is a legacy install option. See "JDK 8 Installation Instructions for Oracle Solaris 11 using IPS packages" for the recommended approach.
Installation of Oracle Solaris SVR4 Packages (.tar.Z
)
Use these instructions if you want to use the pkgadd
utility to install the JDK. This technique allows all users on your system to access Java.
If you do not have root access to your Oracle Solaris system, see "JDK 8 Installation Instructions for Oracle Solaris 11 using IPS packages" to install a private copy of the JDK.
Follow these steps to install:
- Create a new directory to save the download bundle in, and change to that directory.
- Download the bundle.
Before the file can be downloaded, you must accept the license agreement. - Extract the contents of the compressed tar files:
- On SPARC processors:
% zcat jdk-8u_version_-solaris-sparcv9.tar.Z | tar xf - - On x64/EM64T processors:
% zcat jdk-8u_version_-solaris-x64.tar.Z | tar xf -
The first command creates a number of directories (SUNWj8rt
,SUNWj8dev
,SUNWj8cfg
,SUNWj8man
, andSUNWj8jmp
) plus a few files in the current directory.
- On SPARC processors:
- Assume the root role.
You can use theroles(1)
command to determine whether you are able to assume the root role. - Uninstall any earlier installation of the JDK packages.
If your machine has an earlier 32-bit or 64-bit version of the JDK installed in the default location (/usr/jdk/jdk1..0___), you must uninstall it before installing a later version at that location.
You can skip this step if you intend to install the JDK in a non-default location. For details, see "Selecting the Default Java Platform". - Run the
pkgadd
command to install the packages.
pkgadd -d . SUNWj8rt SUNWj8dev SUNWj8cfg SUNWj8man
The command installs the JDK into /usr/jdk/jdk1.8.0_
version
.
See the pkgadd(1)
and admin(4)
man pages for information on installing the JDK in a non-default location.
7. Japanese users: Install man pages.
If your machine has an earlier version of the Japanese man pages already installed in usr/jdk/jdk1.8.0_
version
, you must uninstall that package before installing this version of the Japanese man pages at that location. Remove that package by running:
pkgrm SUNWj8jmp
Then run the pkgadd
command to install the new Japanese man page package.
pkgadd -d . SUNWj8jmp
- To save space, delete the
tar
files and extractedSUNW*
directories. - Exit the root role.
No need to reboot.