[Python-Dev] A Desperate Plea For Introspection (aka: BDFAP Needed) (original) (raw)
Christian Heimes lists at cheimes.de
Fri Jun 22 21:25:14 CEST 2012
- Previous message: [Python-Dev] A Desperate Plea For Introspection (aka: BDFAP Needed)
- Next message: [Python-Dev] A Desperate Plea For Introspection (aka: BDFAP Needed)
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Am 22.06.2012 21:10, schrieb Yury Selivanov:
I think that if a function lacks an annotation, that should be reflected in the same way for its signature.
Currently: if hasattr(signature, 'returnannotation'): If we use Signature.empty: if signature.returnannotation is not signature.empty: So (in my humble opinion) it doesn't simplify things too much. And also you can use 'try .. except AttributeError .. else' blocks, which make code even more readable.
The second form has two benefits:
you get a sensible error message when you mistype the name of the attribute. hasattr(signature, 'return_annotatoin') is clearly an error, hard to notice with the naked eye and passes silently.
modern Python IDEs have code completion. "signature.re is not signature.em" safes key strokes.
Christian
- Previous message: [Python-Dev] A Desperate Plea For Introspection (aka: BDFAP Needed)
- Next message: [Python-Dev] A Desperate Plea For Introspection (aka: BDFAP Needed)
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]