[Python-Dev] [Python-checkins] cpython: Changed importlib tests to use assertIs, assertIsInstance, etc., instead of (original) (raw)
Terry Reedy tjreedy at udel.edu
Wed Jun 27 22:34:13 CEST 2012
- Previous message: [Python-Dev] PEP 423 : naming conventions and recipes related to packaging
- Next message: [Python-Dev] [Python-checkins] cpython: Changed importlib tests to use assertIs, assertIsInstance, etc., instead of
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
On 6/27/2012 3:26 PM, eric.smith wrote:
http://hg.python.org/cpython/rev/9623c83ba489 changeset: 77825:9623c83ba489 user: Eric V. Smith <eric at trueblade.com> date: Wed Jun 27 15:26:26 2012 -0400 summary: Changed importlib tests to use assertIs, assertIsInstance, etc., instead of just assertTrue.
You forgot assertIsNone ;-) or was that intentional?
- self.assertTrue(loader is None) + self.assertIs(loader, None)
self.assertIsNone(loader)
tjr
- Previous message: [Python-Dev] PEP 423 : naming conventions and recipes related to packaging
- Next message: [Python-Dev] [Python-checkins] cpython: Changed importlib tests to use assertIs, assertIsInstance, etc., instead of
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]