[Python-Dev] Pep 550 module (original) (raw)

Joao S. O. Bueno jsbueno at python.org.br
Mon Aug 28 10:17:46 EDT 2017


Well, this talk may be a bit of bike-shedding, but

+1 for a separate module/sub module

And full -1 for something named

"dynscopevars"

That word is unreadable, barely mnemonic, but plain "ugly" - (I know that this is subjective, but it is just that :-) )

Why not just "execution_context" or "sys.execution_context" ?

"from execution_context import Var, lookup, set, LogicalContext, run_with "

On 27 August 2017 at 12:51, Jim J. Jewett <jimjjewett at gmail.com> wrote:

I think there is general consensus that this should go in a module other than sys. (At least a submodule.)

The specific names are still To Be Determined, but I suspect seeing the functions and objects as part of a named module will affect what works. So I am requesting that the next iteration just pick a module name, and let us see how that looks. E.g import dynscopevars user=dynscopevars.Var ("username") myscope=dynscopevars.getcurrentscope() childscope=dynscopevars.Scope (parent=myscope,user="bob")

-jJ


Python-Dev mailing list Python-Dev at python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/ jsbueno%40python.org.br -------------- next part -------------- An HTML attachment was scrubbed... URL: <http://mail.python.org/pipermail/python-dev/attachments/20170828/7452622e/attachment.html>



More information about the Python-Dev mailing list