[dcl.fct.spec] (original) (raw)

9 Declarations [dcl.dcl]

9.2 Specifiers [dcl.spec]

9.2.3 Function specifiers [dcl.fct.spec]

Afunction-specifiercan be used only in a function declaration.

At most one explicit-specifier and at most one virtual keyword shall appear in a decl-specifier-seq.

The virtual specifier shall be used only in the initial declaration of a non-static member function; see [class.virtual].

If the constant expression evaluates to true, the function is explicit.

Otherwise, the function is not explicit.

A ( token that follows explicit is parsed as part of the explicit-specifier.

[Example 1: struct S { explicit(sizeof(char[2])) S(char); explicit(sizeof(char)) S(bool); }; — _end example_]