The internal closure functions (eg. wrapper functions used by decorators) should not use generic names like inner() or wrapper(), but descriptive names so that they make sense when read in a traceback. IOW, you shouldn't have to look up the source code to figure out what decorator's wrapper is found in the traceback.
Thanks for the patch! I will try to find some time to do a proper review if someone else doesn't beat me to it (although first glance seems to suggest it all looks fine).
Sorry, been busy. I will definitely get to it this week. On Sun, Jan 15, 2012 at 19:58, Berker Peksag <report@bugs.python.org> wrote: > > Berker Peksag <berker.peksag@gmail.com> added the comment: > > Hi Brett, did you have a chance to review the patch I submitted? > > ---------- > > _______________________________________ > Python tracker <report@bugs.python.org> > <http://bugs.python.org/issue13588> > _______________________________________ >