[Python-Dev] Pep 550 module (original) (raw)

Nick Coghlan ncoghlan at gmail.com
Tue Aug 29 06:53:15 EDT 2017


On 28 August 2017 at 01:51, Jim J. Jewett <jimjjewett at gmail.com> wrote:

I think there is general consensus that this should go in a module other than sys. (At least a submodule.)

The specific names are still To Be Determined, but I suspect seeing the functions and objects as part of a named module will affect what works.

Given the refocusing of the PEP on the context variable API, with the other aspects introduced solely in service of making context variables work as defined, my current suggestion would be to make it a hybrid Python/C API using the "contextvars" + "_contextvars" naming convention.

Then all most end user applications defining context variables would need is the single line:

from contextvars import new_context_var

_contextvars would contain the APIs that only the interpreter itself can implement, while contextvars would provide a home for any pure Python convenience APIs that could be shared across interpreter implementations.

Cheers, Nick.

-- Nick Coghlan | ncoghlan at gmail.com | Brisbane, Australia



More information about the Python-Dev mailing list